Back to overview
Resolved
Some services are down
Aug 1, 2026 at 7:20am UTC
Affected services
Bullets Web App
API
CDN
Affiliates
Wallets
Other (Ignore)
Resolved
Aug 1, 2026 at 7:20am UTC
We have been notified, we will be working on it.
Affected services